Cyberpunk 2077 registry

This is the registry for Cyberpunk 2077. It is required to install updates to the game.

This registry is for v1.04. Change the options below to switch to v1.05 and newer versions.

Customize this registry

Help

1.04 = 3214677, 1.05 = 3235023, 1.1 = 3256355, 1.11 = 3266445, 1.2 = 3318102, 1.22 = 3354524
1.03 = xxx310, 1.04 = xxx691, 1.05 = xxx789, 1.06 = xxx849, 1.1 = xxx321, 1.11 = xxx801, 1.2 = xxx814, 1.22 = xxx536

Posted under Games

Callisto Site owner

Posted 6 months ago

Windows Registry Editor Version 5.00

; Cyberpunk 2077 registry
; Generated by RegFiles.net
; https://www.regfiles.net/registry/cyberpunk-2077-registry

[HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\GOG.com\Games\1423049311]
"buildId"=""
"dependsOn"=""
"DLC"=""
"exe"="\\bin\\x64\\Cyberpunk2077.exe"
"exeFile"="Cyberpunk2077.exe"
"gameID"="1423049311"
"gameName"="Cyberpunk 2077"
"INSTALLDATE"="2020-12-12 10:00:00"
"installer_language"="english"
"lang_code"="en-US"
"language"="english"
"launchCommand"="\\bin\\x64\\Cyberpunk2077.exe "
"launchParam"=""
"osbit"="64"
"path"=""
"productID"="1423049311"
"startMenu"="Cyberpunk 2077"
"startMenuLink"="C:\ProgramData\Microsoft\Windows\Start Menu\Programs\Cyberpunk 2077 [GOG.com]\Cyberpunk 2077"
"supportLink"=""
"uninstallCommand"="\\unins000.exe"
"ver"=""
"workingDir"=""

The reverse of this registry is generated automatically. If you have other apps or games by the same company or developer, this may also remove registry required for those, too. Please check the registry below before using it.
Windows Registry Editor Version 5.00

; Cyberpunk 2077 registry
; Generated by RegFiles.net
; https://www.regfiles.net/registry/cyberpunk-2077-registry

[-HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\GOG.com\Games\1423049311]

Comments

Posted by mklim on

There is an error, Wow6432Node is repeated twice in the registry path. Other than that, works great!

Posted by Callisto Site owner on

Thanks @mklim, fixed!

Posted by PirateOmega on

From 1.05 to 106 you need to edit "ver"="Build_3233390Change_4173226"

Posted by PirateOmega on

to update from 1.04 to 1.05 and 1.05 to 106 you need to change "ver" and "buildId" with the correc one of the 2 version.

Posted by S1RF4B1O on

can't install 1.05 to 1.06 what do i need to change? to what?

Posted by S1RF4B1O on

Finally did it Change ver in this registry to Build_3235023Change_4177747

Posted by atseiny on

@S1RF4B1O how about the "buildId?

Posted by Callisto Site owner on

Thanks everyone. Registry updated with a dropdown for the version/build number.

Posted by GTurkistane on

you must also change the gameid to 53942626113358691 if you want to update from 1.04 to 1.05

Posted by Callisto Site owner on

Thanks @GTurkistane. Updated.

Posted by Sereno011 on

To update from 1.05 to 1.06, I had to change buildId=53968439607309789 as well for GOG version.Credit to anadius1 on reddit

Posted by xyzan on

What is the BuildID for 1.03?

Posted by xyzan on

how do i change to buildId=53968439607309789

Posted by Callisto Site owner on

Build ID 53968439607309789 added.Does anyone know the values for "ver"?

Posted by reinaldooo on

BuildId for 1.1:54048283519167321ver for 1.1:Build_3256355Change_4197920

Posted by Callisto Site owner on

Thanks @reinaldooo, build & version added for 1.1

Posted by Bala on

Good

Posted by pohytos on

Update from 1.11 to X.XXbuildid: 54078989483766801ver: Build_3266445Change_4208621

Posted by Callisto Site owner on

Thanks @pohytos, updated for 1.11

Posted by Frens on

Update from 1.12 to 1.2: build id 54102433288602814 ver: Build_3318102Change_4256789

Posted by Callisto Site owner on

Thanks @Frens, updated for 1.2

Posted by rseke on

can i change gamefiles path and temp folder path? I got "not enough space error"

Posted by Callisto Site owner on

@rseke yes, you'll need to move the game to a disk with enough free space to patch it. You can update the Path field here to the new path. Once you have patched it, you can move it back and update the registry again with the original path.

Posted by rseke on

Iam tried change the path in reg file but patcher i dont know why unpack patch files to default game installation path on disk C not to path which i wrote in reg file

Posted by phantom54 on

if your patcher installing update on C:\ - that means your game files modiffed/corrupted. patcher doesnt check sums / doesnt remind you about modded files. keep it in mind and keep backups

Posted by Louisepalmer on

Hi,For 1.22:"ver"="Build_3354524Change_4287350""buildId"="54338098657774536"Have a nice day ;)

Posted by Callisto Site owner on

Thanks @Louisepalmer, updated!

Posted by someguy on

Was having an issue updating 1.2 to 1.2.1 and then 1.22. Checked the gogdb.org page and found the correct BUILDID for anyone else having an issue updating:

1.2 to 1.2.1 - BUILDID=54250516403328098 ver=Build_3318102Change_4256789
and
1.2.1 to 1.22 - BUILDID=54290602071723094 ver=Build_3354524Change_4287350

Post a comment

Register or login to make a comment.